Changing Web Browser Support

EmblemHealth is dedicated to the security and privacy of your information. On May 12, 2018, we will be changing our support for certain website browsers, like Google Chrome, Mozilla Firefox, and Internet Explorer. Specifically, we will no longer support the TLS 1.0 & 1.1 encryption protocol. This means that older internet browsers will not be able to access the secure (HTTPS) portions of our websites. EmblemHealth will continue to support TLS 1.2.

What are TLS 1.0 & TLS 1.1, and why are they going away?

Transport Layer Security (TLS) encryption protocol allows secure communication to flow between two computer applications, for example web browsers or mobile apps and back end servers.

We take the protection of your data and health information very seriously. TLS 1.0 & 1.1 encryption protocols are now obsolete and in order to conform with industry best practices, we are no longer supporting them.

How will I be affected?

If you’re using the most up to date web browsers you will not be affected. However, if you are using an old internet browser, you will not be able to access our secure (HTTPS) portions of our websites.

Please refer to the browser compatibility guidelines below:

Microsoft Internet Explorer (IE)
Microsoft Edge Compatible with TLS 1.1 or higher by default.
Desktop and mobile IE version 11 Compatible with TLS 1.1 or higher by default

If you see the "Stronger security is required" error message, you may need to turn off the TLS 1.0 setting in the Internet Options | Advanced Settings list.
Desktop IE versions 8, 9, and 10 Compatible only when running Windows 7 or newer, but not by default.

Windows Vista, XP and earlier are incompatible and cannot be configured to support TLS 1.1 or TLS 1.2.
Desktop IE versions 7 and below Not compatible with TLS 1.1 or higher encryption
Mobile IE versions 10 and below Not compatible with TLS 1.1 or higher encryption
 
Mozilla Firefox
Compatible with the most version, regardless of operating system.
Firefox 27 and higher Compatible with TLS 1.1 or higher by default.
Firefox 23 to 26 Compatible, but not by default. Use about:config to enable TLS 1.1 or TLS 1.2 by updating the security.tls.version.max config value to 2 for TLS 1.1 or 3 for TLS 1.2.
Firefox 22 and below Not compatible with TLS 1.1 or higher encryption.
 
Google Chrome
Compatible with the most recent version, regardless of operating system.
Google Chrome 38 and higher Compatible with TLS 1.1 or higher by default.
Google Chrome 22 to 37 Compatible when running on Windows XP SP3, Vista, or newer (desktop), OS X 10.6 (Snow Leopard) or newer (desktop), or Android 2.3 (Gingerbread) or newer (mobile).
Google Chrome 21 and below Not compatible with TLS 1.1 or higher encryption.
 
Google Android OS Browser
Android 5.0 (Lollipop) and higher Compatible with TLS 1.1 or higher by default.
Android 4.4 (KitKat) to 4.4.4 May be compatible with TLS 1.1 or higher. Some devices with Android 4.4.x may not support TLS 1.1 or higher.
Android 4.3 (Jelly Bean) and below Not compatible with TLS 1.1 or higher encryption.
 
Apple Safari
Desktop Safari versions 7 and higher for OS X 10.9 (Mavericks) and higher Compatible with TLS 1.1 or higher by default.
Desktop Safari versions 6 and below for OS X 10.8 (Mountain Lion) and below Not compatible with TLS 1.1 or higher encryption.
Mobile Safari versions 5 and higher for iOS 5 and higher Compatible with TLS 1.1 or higher by default.
Mobile Safari for iOS 4 and below Not compatible with TLS 1.1 or higher encryption.